R04A - Direccionamento IPv4 e enrutamento básico

Volver ao curso

Antes de comezar, botemos unha ollada á diferencia entre esquema físico (indica ubicacións nos racks, cableado, rosetas, etc), e esquema lóxico (só símbolos, direccións IP, e datos relevantes a nivel lóxico). Aínda que o habitual é mesturar un pouco de todo:

Esquema físico (esquerda) é lóxico (dereita). [NON son da mesma rede]
Esquema físico (esquerda) é lóxico (dereita). [NON son da mesma rede]

Os símbolos que máis se repiten no esquemas lóxicos son:

Router e switch según la simbología definida por Cisco
Router e switch según la simbología definida por Cisco
  1. EXERCICIO. Debuxa o esquema lóxico dunha rede 192.168.0.0 con máscara de subrede 255.255.255.0 (“/24”). Os equipos se conectan todos a un switch. Na rede hai:

    O prefixo CIDR “/24” significa o mesmo que a máscara de subrede 255.255.255.0, que en binario é 11111111.11111111.11111111.00000000, (3 bytes de rede, 1 byte para hosts).

Direccións IP con clase

Esta clasificación era ríxida, e non precisaba nin toleraba máscaras de subrede. É dicir, unha rede clase A sempre tería 255.0.0.0 de máscara, declarada ou non. Actualmente traballamos con direccións IPs sen clase, nas que podemos empregar a máscara que precisemos de acordo co número de hosts.

  1. EXERCICIO. Debuxa o esquema lóxico de dúas redes unidas por un router.

    Repara en que o router comunica a rede 10.0.0.0/24 e a rede 172.16.0.0/24

Dirección de rede e dirección IP de difusión (broadcast)

Supón que temos a típica rede 192.168.0.0 con máscara 255.255.255.0. Esto es en binario: 11111111.11111111.11111111.00000000, por tanto temos 24 bits para rede e 8 bits para hosts (equipos conectados). Así, o número de equipos conectados será:

$$ Nº\ hosts=2^n $$

$2^8=256$ hosts. POIS NON, INCORRECTO. Temos que ter en conta que en redes IP:

Aplicando este descarte, a fórmula correcta sería:

$$ Nº\ hosts=2^n -2$$

Onde $"n"$ é o número de bits asignados a hosts.

No primeiro exercicio, o número de hosts posibles sería $2^8-2=254$, así que para a rede 192.168.0.0 con máscara 255.255.255.0:

O máis habitual e tamén o máis cómodo é referirse a toda a rede anterior como 192.168.0.0/24 (dirección de rede / prefixo CIDR).

Direccións IP sen clase (CIDR)

No principio dos tempos:

Pero iso desperdiciaba direccións, polo que se deseñou o enrutamiento sen clase (CIDR) (coidado co nome porque da lugar a enganos). Sempre se usa o sistema sen clase, por iso hai que especificar a máscara de subrede.

Así, a rede 192.168.0.0, podería ter calquera máscara: /12, /16, /25, /25, /26…:

Á máscara de subred en notación “/24“, “/8”… se le llama prefijo CIDR ou “lonxitude de prefixo”.

  1. EXERCICIO. Repite os exercicios 1 y 2 en Cisco Packet Tracer 7.1.

    Comandos do exercicio 2 (Router R1):

    enable
    configure terminal
    !
    interface GigabitEthernet 0/0
    ip address 10.0.0.254 255.255.255.0
    no shutdown
    !
    interface GigabitEthernet 0/1
    ip address 172.16.0.254 255.255.255.0
    no shutdown
    !
    end
    copy running-config startup-config

    Para probalo, fai ping entre os equipos:

A porta de enlace (“gateway”, “ruta de último recurso”) é a dirección IP do equipo ó que se envían os paquetes que están destinados a cualquera rede que non sexa na que estás ou outra coñecida. Isto implica todo o tráfico dirixido a Internet.

  1. EXERCICIO. Dada a rede 172.18.0.0, calcula o número de hosts posibles que tería cunha máscara de subrede /16 (255.255.0.0), /20, e /23. Queres usar calculadora?

Operación AND coa máscara de subrede

Se convertes todo a binario, ó facer a operación lóxica AND entre a IP dun host e a súa máscara de subrede, obterás a dirección de rede.

  1. EXERCICIO. Indica a ruta á configuración IP da máquina na que estás traballando (en clase ou na casa). Indica sistema operativo.
  2. EXERCICIO. Obtén a dirección de rede e a dirección IP de difusión en formato “longitud de prefixo CIDR” (/nºceros) das seguintes redes:

Direccións IP públicas e privadas

As direccións IP privadas non son direccionables en Internet. Isto quere dicir que os routers que se conectan a Internet non reenvían paquetes a Internet cuxa IP de destino sea privada (con destino ó interior dunha LAN). De feito, os descartan automaticamente

“Feita a lei, feita a trampa”: ¿Se o anterior é certo, como é que podes navegar usando o teu PC? Gracias á NAT, unha técnica de routing que enmascara a túa IP privada dentro da IP pública do router.

A combinación “IPs privadas” + “NAT” fai posible que as redes locais (LAN) se conecten a Internet.

  1. EXERCICIO. Comproba a túa dirección IP privada na configuración de Windows. Compártea co teu vecin@. Agora comproba tu dirección IP pública aquí. Debuxa o diagrama da rede do teu PC, do do lado, e dos elementos que os unen.

Direccións IP privadas

Hai tres rangos de IPs privadas:

Todas as demais direccións IP son públicas, e como tais se pagan. A túa conexión a Internet implica unha IP pública (para ti só ou compartida con outros suscriptores).

É unha malísima práctica usar direccións IP públicas dentro dunha LAN.

  1. EXERCICIO. Indica se as seguintes IPs son públicas ou privadas:

Asignación de direccións automática o manual

Temos dúas formas de configurar a dirección IP dun host nunha rede:

O habitual é activar un servidor DHCP, pero deixando libres unhas poucas direccións para servidores o simplemente máquinas que queiras tener localizadas.

  1. EXERCICIO. Copia este esquema e realiza a configuración en Packet Tracer:

    As IPs no switch0 se asignan da seguinte maneira:

    enable
    configure terminal
    interface vlan 1
    ip address 192.168.0.2 255.255.255.0
    no shutdown
    end
    copy running-config startup-config

    Agora pon dous PCs máis conectados a switch 0 como clientes DHCP. Para que estes equipos poidan recibir IP, deberás crear un servidor DHCP no router:

    ip dhcp excluded-address 192.168.0.1 192.168.0.10
    ip dhcp pool MIPOOLDHCP
    network 192.168.0.0 255.255.255.0
    default-router 192.168.0.1
    end
    copy running-config startup-config

A primeira liña serve para deixar un espazo para direccións estáticas, un bo hábito. Polo menos tes que deixar como estática a propia IP do router que fai de servidor DHCP.

Outro tipo de direccións: Link-local IPv4 Son direccións que se toman automaticamente cando host ten o cliente DHCP activado pero non existe servidor que lle asigne.169.254.0.0/16 ou, o que é o mesmo, de 169.254.0.0 a 169.254.255.255. Isto permite comunicar equipos conectados a un switch sen que exista servidor DHCP. Se se combina con técnicas de anuncio de nome de dominio como mDNS ou Bonjour, é moi cómodo (exemplo: raspberrypi.local)

Imos quedar sen IPs

O protocolo IPv4 ten direccións IP de 32 bits. Al máis de 4000 millóns de direccións. Moito para os anos 80, suficiente para os 90 e… cagámola!

Solucións e artimañas:

 Rutas estáticas e rutas de último recurso

Podes ver exemplos no capítulo sobre nodos MikroTik.


Creado para C2001003 - “Radioenlaces e redes metropolitanas sen fíos” e actualizado para V2101002 por Daniel Ríos Suárez.

Licenciado baixo a Licenza Creative Commons Recoñecemento Compartir igual 4.0

Este curso virtual elaborouse para ser impartido no plan anual de formación do profesorado de FP da Consellería de Cultura, Educación e Ordenación Universitaria, Xunta de Galicia

Quedan fora desta licenza os textos, imaxes, recursos... que manteñen a súa propia licenza, sinalada en cada caso.

Úsanse imaxes e recursos de producción propia, que se publican no Dominio público ou con licenza CC BY-SA, outras de dominio público, con licenza creative commons, GNU... tomados prefentemente de bancos de recursos educativos abertos. Tamén se empregan ---acolléndose ao "Dereito de cita" --- imaxes, e recursos diversos de diferentes páxinas web, e se enlaza a súa licenza ao pé dos propios recursos ou na páxina coa atribución da propiedade intelectual dos ODE empregados, dereitos reservados que manteñen integramente. Se detecta algunha imaxe, recurso... con dereitos reservados, agradecemos nos informe para retirala.


Volver ao curso

  1. Ou redes distintas, no caso de de switches capa 3 usando VLANs. Tamén moitos switches capa 2 poderán ter dominios de difusión separados mediante VLANs, pero non interconectados entre eles. ↩︎